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About flattening artwork

 

When artwork contains transparency, Adobe

 

®

 

 Illustrator

 

®

 

 performs a process called 

 

flattening

 

 before printing or 
saving the artwork. During flattening, Illustrator looks for areas where transparent objects overlap other objects and 
isolates these areas by dividing the artwork into components. Illustrator then analyzes each component to determine 
if the artwork can be represented using vector data or if the artwork must be rasterized.

For most artwork, the number of components and the time required to compute them is reasonable, but complex 
artwork may result in thousands of components, some of which are smaller than a pixel. As a result, flattening 
complex artwork may take considerable time and resources. The Flattening Preview palette lets you specify flattener 
options and preview the expected results. This feedback increases the predictability of the flattening process, 
simplifies the print workflow, and allows for a more targeted control over the flattening parameters.

You can find more information on printing and flattening artwork with transparency in the following places:

 

•

 

The 

 

Printing and Exporting Files from Adobe Illustrator 10

 

 booklet, included with the Illustrator application.

 

•

 

The 

 

Printing and Exporting Artwork

 

 white paper, included on the Illustrator CD-ROM and also available for 
download at www.adobe.com/products/illustrator.

 

•

 

The Adobe Illustrator User to User forum, a public forum which offers a wealth of tips and answers to frequently-
asked questions, found at www.adobe.com/support/forums.

 

•

 

The 

 

Achieving Reliable Print Output with Transparency

 

 white paper, available for download at www.adobe.com.

 

Installing the Flattening Preview palette

 

You must install the Flattening Preview plug-in before you can display the Flattening Preview palette in Illustrator.

 

To install the Flattening Preview palette:

 

Drag a copy of the Flattening Preview plug-in, located in the Illustrator 10/Utilities/Flattening Preview folder, into 
the Illustrator 10/Plug-ins folder.

 

Specifying flattening options

 

Flattening options allow you to control the parameters that Illustrator uses during the flattening process. Keep in 
mind that choosing whether and how aggressively to rasterize artwork depends on your intent (fast proof vs. 
high-quality print), as well as the time and computing resources that are available. For some print jobs, it may be 
better to rasterize very complex areas in the document rather than trying to preserve them in vector form.

If the artwork does not contain transparency, the document will not be flattened and the flattening settings 
are not relevant. Use the Transparent Objects preview option to determine if artwork contains transparency. 
(See “Previewing flattened artwork” on page 3.)

 

Note:

 

 Settings entered in the Flattening Preview palette are immediately reflected in the flattening settings in the 
Document Setup > Transparency dialog box. Also, the Ignore Overprinting in Composite Output option is synchronized 
between the Flattening Preview palette and the Print dialog box.

http://www.adobe.com/products/illustrator
http://www.adobe.com/support/forums
http://www.adobe.com
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To specify flattening options:

 

1

 

Do one of the following:

 

•

 

Choose Window > Flattening Preview.

 

•

 

Choose File > Document Setup, and choose Transparency from the pop-up menu at the top of the dialog box.
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Drag the Raster/Vector slider or enter a value to specify the degree of rasterization in complex areas of the artwork. 
The right position (100) on the slider is recommended for the highest-quality results. In this position, no areas of 
the artwork are rasterized for performance reasons. (Some rasterization may still occur if there is no other way of 
representing the artwork in PostScript

 

®

 

.) The intermediate positions on the slider result in rasterizing areas that are 
complex and preserving simple ones in vector form. For example, a single transparent pattern may be preserved 
intact, while portions of overlapping patterns may be rasterized. When the slider is in the left position (0), all objects, 
transparent or not, will be rasterized. 

 

Note:

 

 When the flattening slider is at the rightmost position, no rasterization occurs for performance reasons; therefore 
the Rasterization Resolution and the Clip Complex Regions options are disabled. When the slider is at the leftmost 
position, the entire document will be rasterized; therefore the four flattening checkboxes are disabled.
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Specify a rasterization resolution that is used to rasterize complex areas (as determined by the Raster/Vector 
slider). The default value of 300ppi is usually appropriate. However, if small fonts or fine objects will be rasterized or 
if the output is a high quality print, higher values (600ppi or more) are necessary. Using very high values is not 
recommended because it can degrade performance and increase spool size without noticeable quality improvement. 
Changing the rasterization resolution has no effect on the flattening preview, but it is an important parameter of the 
flattening process.
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Set additional flattening options. The availability of options depends on the artwork’s content and the position of 
the Raster/Vector slider:

 

•

 

Select Convert All Text to Outlines if the artwork contains elements that will cause portions of text to be converted 
to outlines. For example, text that is used as a clipping path and text that has a pattern fill or stroke is converted 
to outlines during flattening. The Convert All Text to Outlines option ensures that the width of all text in the 
artwork stays consistent. Selecting this option, however, causes small fonts to appear noticeably thicker (especially 
when printed on lower-end printing systems). In addition, it may make small fonts less readable and significantly 
degrade flattening performance. You may achieve better results by manually converting the affected text to 
outlines in Illustrator.

 

•

 

Select Convert All Strokes to Outlines if the artwork contains elements that will cause portions of strokes to be 
converted to outlines. For example, portions of strokes that interact with transparent artwork are converted to 
outlines during flattening. The Convert All Strokes to Outlines option ensures that the width of all strokes in the 
artwork stays consistent. Selecting this option, however, causes thin strokes to appear slightly thicker (especially 
when printed on lower-end printing systems). In addition, it changes the appearance of strokes and may signifi-
cantly degrade flattening performance. You may achieve better results by manually converting the affected strokes 
to outlines in Illustrator.

 

•

 

Select Clip Complex Regions to ensure that the boundaries between vector artwork and rasterized artwork fall 
along object paths. This option reduces stitching artifacts that result when part of an object is rasterized while 
another part of the object remains in vector form (as determined by the Raster/Vector slider). However, selecting 
this option may result in extremely complex clipping paths, which take significant time to compute and can cause 
errors when printing.

 

Note:

 

 Some print drivers process raster and vector art differently, and this can also result in color stitching. You may be 
able to minimize stitching problems by disabling some print-driver specific settings (and bypassing the Clip Complex 
Regions option, which increases file complexity). 
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•

 

Select an overprint option based on the preview context. (See “Previewing flattened artwork” on page 3.) For EPS 
output and Legacy output, select Preserve Overprints When Possible to simulate overprinting for objects involved 
in transparency, but preserve native overprint instructions for objects not involved in transparency. This option 
makes sense when printing to a separations printer, in which case simulated or native overprinting will end up 
producing the same appearance. Deselect Preserve Overprints When Possible to simulate the appearance of 
overprinting (flatten the overprint) for all objects. For Composite output, deselect Ignore Overprinting in 
Composite Output to simulate the appearance of overprinting (flatten the overprint) for all objects. Select Ignore 
Overprinting in Composite Output to ignore overprint instructions for all objects. 

 

Important:

 

 Do not select Preserve Overprints When Possible when saving files for use in page layout applications. With 
this option, overprint areas that interact with transparency are flattened, while overprinting in other areas is preserved. 
The results are unpredictable when the file is output from a page layout application.

 

Diagram of how Illustrator handles overprinted objects during flattening.

 

Note:

 

 Changes you make to the flattening settings are applied to the document, regardless of whether or not you preview 
the flattened artwork.

 

Previewing flattened artwork

 

The preview options in the Flattening Preview palette allow you to preview where certain events occur in the 
flattened artwork. You can use this information to adjust the flattening options.

 

Note:

 

 The Flattening Preview palette is not intended for precise previewing of spot colors, overprints, and blending modes. 
Use Overprint Preview mode in Illustrator to preview spot colors, overprints, and blending modes as they will appear 
when output.

 

To preview flattened artwork:

 

1

 

If the Flattening Preview palette is not showing, choose Window > Flattening Preview to display it.

 

2

 

Choose a preview mode from the palette menu:

 

•

 

Quick Preview to compute the quickest preview.

 

•

 

Detailed Preview if you want to preview flattening for outlined text and all rasterized regions. These events take 
longer to compute and are available only when Detailed Preview is selected.
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Choose a preview context from the palette menu:

 

•

 

Preview for EPS Output to preview the flattening that will occur when you save the artwork to EPS 9 or EPS 10 
format. In most cases, you can use this option to preview how artwork will be flattened when it is printed to 
separations. Only printable, visible layers are shown in the preview, regardless of the Separate option in the 
Separation Setup dialog box. 

 

•

 

Preview for Composite Output to preview the flattening that will occur when you print the artwork on a 
composite printer. Overprint behavior is controlled by the Ignore Overprinting in Composite Output option.

 

•

 

Preview for Legacy Output to preview the flattening that will occur when you save the artwork to Illustrator 8 
format, PDF 1.3 format, or EPS 8 format, or when you choose the Object > Flatten Transparency command. 
All text is converted to outlines in this preview context, and all spot colors are converted to CMYK (although this 
color conversion is not displayed in the Flattening Preview palette).

 

Note:

 

 The Flattening Preview palette cannot display how artwork will look when printed on a non-PostScript printers. 
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Select Preview options. The availability of options depends on the content of the artwork, the flattening settings, 
the preview mode, and the preview context:

 

•

 

Rasterized Complex Regions to preview the areas that will be rasterized for performance reasons (as determined 
by the Raster/Vector slider). Keep in mind that the boundary of the previewed area has a higher probability of 
producing stitching problems (depending on the print driver settings and the rasterization resolution). Select the 
Clip Complex Regions option to minimize stitching problems. (See “Specifying flattening options” on page 1.) 

 

•

 

Transparent Objects to preview the objects that are sources of transparency, such as transparent objects, 
objects with blending modes, and opacity masks. In addition, styles and effects may contain transparency, 
and overprinted objects may be treated as sources of transparency if they are involved in transparency or if the 
overprint needs to be flattened. 

 

•

 

All Affected Objects to preview all objects that are involved in transparency, including transparent objects and 
objects that are overlapped by transparent objects. The previewed objects will be affected by the flattening 
process—their strokes or patterns will be expanded, portions of them may get rasterized, and so on. 

 

•

 

Affected Linked EPS Files to preview all linked EPS files that are affected by transparency. Such files will be printed 
first, under all other objects. To prevent this, embed the linked files.

 

•

 

Expanded Patterns to preview all patterns that will be expanded because they are involved in transparency.

 

•

 

Outlined Strokes to preview all strokes that will be outlined because they are involved in transparency or because 
the Convert All Strokes to Outlines option is selected. (See “Specifying flattening options” on page 1.)

 

•

 

Outlined Text to preview all text that will be outlined because it is involved in transparency or because the Convert 
All Text to Outlines option is selected. (See “Specifying flattening options” on page 1.) This option is available only 
when Detailed Preview is selected in the palette menu.

 

Note:

 

 In the final output, outlined strokes and text may appear slightly different than native ones, especially very thin 
strokes and very small text. However, the Flattening Preview palette does not display this altered appearance.

 

•

 

All Rasterized Regions to preview objects and intersections of objects that will be rasterized because there is no 
other way of representing them in PostScript. For example, the intersection of two transparent gradients will 
always be rasterized, even when the Raster/Vector slider is at the right (100) position. Rasters of this kind are 
clipped around objects and are usually not a source of stitching or quality problems. This option is available only 
when Detailed Preview is selected in the palette menu.

 

Note:

 

 Illustrator uses the Gradient Mesh resolution (in the Document Setup dialog box) to rasterize regions where 
gradients, meshes, or gradients and meshes overlap. See Illustrator online Help for more information on setting the 
Gradient Mesh resolution.
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Click the Refresh button. The areas of the artwork where selected events occur are highlighted in color, while the 
rest of the artwork appears in grayscale. 
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To magnify the preview, click in the preview area. To pan the preview, hold down the space bar and drag in the 
preview area.

 

Note:

 

 The preview does not show how rasterized areas will appear at the specified rasterization resolution (no matter how 
much you magnify the preview). In addition, the preview does not show images that don't get resampled during flattening 
(such as opaque images that do not interact with transparent objects).
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